通达信短博线利用期货博弈原理、通用源码

[复制链接]
查看1177 | 回复0 | 2022-7-24 08:27:40 | 显示全部楼层 |阅读模式

通达信短博线利用期货博弈原理、通用源码

本指标利用期货原理。超短博弈。
 {立体K线部分}


 STICKLINE(C>=O,L,H,0.00001,0),COLORRED;
STICKLINE(C>O,O,C,2.5,0),COLORRED;
 STICKLINE(C>O,O,C,0.6,0),COLORCC66FF;
 STICKLINE(C<O,O,C,2.5,0),COLORFF6600;
 STICKLINE(C<O,O,C,0.6,0),COLORFF9900;
 STICKLINE(C<O,L,H,0.00001,0),COLORCYAN;
AX:=(2*C-H-L);
 T0:=MAX(H-L,MAX(ABS(H-REF(AX,1)),ABS(L-REF(AX,1))));
 A0:=AX-REF(AX,2);
 A1:=REF(A0,1);
 A2:=REF(A0,2);
 D1:=BARSLAST(A0>A1 AND A0>A2);
 D2:=BARSLAST(A0<A1 AND A0<A2);
 D0:=IF(D1<D2,100,-100);
 DB:REF(REF(C,1)+IF(D0>50,MIN(A0,A1),MAX(A0,A1)),1);


 使用说明:收盘价上穿短博线买入,跌破短博线卖出。
 日线示意图:

636322705.jpg

636322705.jpg

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则