通达信静静简单操盘主图公式

[复制链接]
查看1199 | 回复0 | 2022-7-24 08:24:46 | 显示全部楼层 |阅读模式

通达信静静简单操盘主图公式

参数 M1  2  1000  5  M2  2  1000  15  M3  2  1000  21 M4  2  1000  30  M5  2  1000  43 M6  2  1000  60  M7  2  1000 120                                                                                                                                                MA1:MA(CLOSE,M1);
 MA2:MA(CLOSE,M2),LINETHICK3;
 MA3:MA(CLOSE,M3),LINETHICK2;
 MA4:MA(CLOSE,M4),LINETHICK4;
 MA5:MA(CLOSE,M5),LINETHICK2;
 MA6:MA(CLOSE,M6),LINETHICK4;MA7:MA(CLOSE,M7),LINETHICK2;
 LC:=REF(CLOSE,1);
 RSI1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
 SELL2:=(CROSS(88,RSI1));
 DRAWTEXT(SELL2,HIGH*1.02,'★出'),COLOR00FF00;
 VB1:=C-REF(C,1);
 VB2:=100*EMA(EMA(VB1,6),6)/EMA(EMA(ABS(VB1),6),6);
 VB3:=IF(LLV(VB2,2)=LLV(VB2,7) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
 VB4:=FILTER(VB3=1,5);
 DRAWTEXT(VB4,LOW*0.97,'★ 买'),COLOR00FFFF;DRAWTEXT_FIX(1,0,0,0,HYBLOCK);
 DRAWTEXT_FIX(1,0,0.08,0,DYBLOCK);
 DRAWTEXT_FIX(1,0,0.16,0,GNBLOCK),COLORGREEN;
 YC:=REF(CLOSE,1);
止损价位:=(YC*1.0035*97+0.2)/99.65,COLORRED,LINETHICK0;
 E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
 DRAWTEXT_FIX(1,0.00,0,0,'今阻:'),COLORGREEN;
                                              DRAWTEXT_FIX(1,0.05,0,0,CON2STR(今日阻力,2)),COLORGREEN;
 DRAWTEXT_FIX(1,0.11,0,0,'今撑:'),COLORRED;
                                              DRAWTEXT_FIX(1,0.16,0,0,CON2STR(今日支撑,2)),COLORRED;
 DRAWTEXT_FIX(1,0.22,0,0,'明阻:'),COLORGREEN;
                                              DRAWTEXT_FIX(1,0.27,0,0,CON2STR(明日阻力,2)),COLORGREEN;
 DRAWTEXT_FIX(1,0.33,0,0,'明撑:'),COLORRED;
                                                   DRAWTEXT_FIX(1,0.38,0,0,CON2STR(明日支撑,2)),COLORRED;
 DRAWTEXT_FIX(1,0.44,0,0,'明突:'),COLORYELLOW;
                                                      DRAWTEXT_FIX(1,0.49,0,0,CON2STR(明日突破,2)),COLORYELLOW;
 DRAWTEXT_FIX(1,0.55,0,0,'明转:'),COLORFFFF00;
                                                DRAWTEXT_FIX(1,0.60,0,0,CON2STR(明日反转,2)),COLORFFFF00;
 DRAWTEXT_FIX(1,0.66,0,0,'止损:'),COLORWHITE;
                                                 DRAWTEXT_FIX(1,0.71,0,0,CON2STR(止损价位,2)),COLORWHITE;
 DRAWTEXT_FIX(1,0.00,0.08,0,'所属行业:')COLORYELLOW;
 DRAWTEXT_FIX(1,0.06,0.08,0,HYBLOCK)COLORYELLOW;
 DRAWTEXT_FIX(1,0.20,0.08,0,'所属地区:')COLORYELLOW;
 DRAWTEXT_FIX(1,0.26,0.08,0,DYBLOCK)COLORYELLOW;
 T1:=IF(FINDSTR(EXTERNSTR(0,13),'万元'),STRCAT('敢死队席位:',EXTERNSTR(0,13)),'');
 T2:=IF(FINDSTR(EXTERNSTR(0,12),'。'),STRCAT('智能诊断:',EXTERNSTR(0,12)),'');
 T3:=IF(FINDSTR(EXTERNSTR(0,8),'公告'),STRCAT('年报业绩:',EXTERNSTR(0,8)),'');
 T4:=IF(FINDSTR(EXTERNSTR(0,10),','),STRCAT('主题投资:',EXTERNSTR(0,10)),'');
 T5:=IF(FINDSTR(EXTERNSTR(0,15),'-'),STRCAT('解禁日期:',EXTERNSTR(0,15)),'');
 T6:=IF(FINDSTR(EXTERNSTR(0,1),','),STRCAT('千股千评:',EXTERNSTR(0,1)),'');
 T7:=IF(FINDSTR(EXTERNSTR(0,14),'-'),STRCAT('业绩预报:',EXTERNSTR(0,14)),'');
 T8:=IF(FINDSTR(EXTERNSTR(0,11),'-'),STRCAT('机构评级:',EXTERNSTR(0,11)),'');
 T9:=IF(FINDSTR(EXTERNSTR(0,9),'-'),STRCAT('中报业绩:',EXTERNSTR(0,9)),'');

122299704.JPG

122299704.JPG

 

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则