通达信厉害的MACD指标源码

[复制链接]
查看1223 | 回复0 | 2022-7-24 08:24:36 | 显示全部楼层 |阅读模式

通达信厉害的MACD指标源码

DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORRED,LINETHICK2;
 DEA:EMA(DIF,9),COLORWHITE,LINETHICK2;
 持仓段:=0,COLOR00CFFF;
 空仓段:=0,COLORFFCCFF;
 {STICKLINE(DIF>DEA,-0.5,-0.6,10,1),COLOR00CFFF;
 STICKLINE(DIF<DEA,-0.5,-0.6,10,1),COLORFFCCFF;}
 MACD:(DIF-DEA)*2,COLORSTICK;
 STICKLINE(((MACD<REF(MACD,1)) AND (MACD>0)),0,MACD,1,0),COLORLIBLUE,LINETHICK2;
 STICKLINE(((MACD>REF(MACD,1)) AND (MACD<0)),0,MACD,1,0),COLORFF00FF,LINETHICK2;
 建仓:IF(DIF<0,DIF,0),COLORYELLOW,LINETHICK2;
 加仓:IF(DIF<0,0,DIF),COLORRED,LINETHICK2;
 白线破仓:IF(DIF<DEA,DIF,DEA),COLORWHITE,LINETHICK2;
 趋势强弱:IF(DIF>DEA,DEA,DEA),COLORFF937F,LINETHICK2;
 
AA:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
 二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(AA=2,21)=1;
 DRAWTEXT(二次金叉,0,' 二次金叉'),COLORYELLOW;
 A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
 底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
 STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
 底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK1;
 DRAWTEXT(底背离,0.05,' 底背离'),COLORFF00FF;
 A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
 顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
 顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK1;
 
V2:=IF(CURRBARSCOUNT=1,AMOUNT/1000*240/FROMOPEN/REF(AMOUNT/1000,1)-1,
 AMOUNT/REF(AMOUNT,1)-1),NODRAW,COLORRED;
 
STICKLINE((V2>=1),DIF,DEA,0.5,0),COLORYELLOW;
 DRAWTEXT((V2>=1),DIF*1.15,'放量'),COLOR00FF00;
 
{RMACD:="MACD.MACD";
 H3:=REF(RMACD,3);
 H2:=REF(RMACD,2);
 H1:=REF(RMACD,1);
 H0:=RMACD;
 买:(H2<0 AND H3>H2 AND H2>H1 AND H0>H1)/12;}

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则