通达信原创指数幂boll大盘对比乖离不含未来函数(图解、副图、贴图、通用源码)

[复制链接]
查看1925 | 回复0 | 2022-7-24 08:18:58 | 显示全部楼层 |阅读模式

通达信原创指数幂+boll+大盘对比+乖离不含未来函数(图解、副图、贴图、通用源码)

致意思相差不大。买点不是非常准确,但基本可用。
加入boll轨道是为了帮助观察股价的位置,处在上升、下跌和横盘的情况,可以帮助新手解决观察的问题。其实该指标已经很明显地区分了股价这三类走势。
使用中请多注意柱线颜色等变化,比如:M2和M3之间的红柱线与M1与M2之间的黄色柱线叠加,则说明涨势坚决,上档抛压很轻,股价拉高速度快。但下面红柱,上面绿柱意思说上档抛压比较严重,股价上涨很吃力。尤其是在顶部,出现绿色柱线,则说明有大量的股票在抛卖(庄家出货)。
适用于任何时间段的显示(包括分时),但不建议使用在分钟,如果要使用在分钟则最好是在15分钟以上的走势图上效果比较好。过小的单位显示会压缩而看不清楚。
 

{参数:N:2 120 20;N1:2 200 55;N2:2 200 24;迷糊鱼2010编写}
DRAWTEXT_FIX(1,0.00,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.07,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.06,0,'所属行业:')COLORFF00FF;
DRAWTEXT_FIX(1,0.07,0.06,0,HYBLOCK)COLORFF00FF;
CC:=SQRT(EXP(C/100));
CH:=SQRT(EXP((C+H)/200));
OH:=SQRT(EXP((O+H)/200));
COL:=SQRT(EXP((C+O+L)/300));{指数幂}
STICKLINE(CC>=(REF(CC,1)+OH)/2,COL,CH,0.00001,0),COLORRED;
STICKLINE(CC<(REF(CC,1)+OH)/2,COL,CH,0.00001,0),COLORFF9900;
STICKLINE(CC>(REF(CC,1)+OH)/2,(REF(CC,1)+OH)/2,CC,2.5,0),COLORRED;
STICKLINE(CC>(REF(CC,1)+OH)/2,(REF(CC,1)+OH)/2,CC,0.6,0),COLORCC66FF;
STICKLINE(CC<(REF(CC,1)+OH)/2,(REF(CC,1)+OH)/2,CC,2.5,0),COLORFF6600;
STICKLINE(CC<(REF(CC,1)+OH)/2,(REF(CC,1)+OH)/2,CC,0.6,0),COLORFF9900;{幂K线}
M1:SMA(CC,N1,N2);{迷糊鱼2010编写}
M2:SMA(M1,N1,N2),DOTLINE;
M3:SMA(M2,N1,N2),COLORGREEN;
ZSB:=EMA((CC-REF(CC,1))/(REF(CC,1)*10)-(INDEXC-REF(INDEXC,1))/(REF(INDEXC,1)*10),5);
STICKLINE(ZSB>0,M1,M2,0.3,0.1),COLORYELLOW;
STICKLINE(ZSB<0,M1,M2,0.3,0.1),COLORGREEN;{大盘对比}
ZJ:=(CC*2+CH+COL)/4;
GL:=EMA(ZJ,13)-EMA(ZJ,21);
GM1:=EMA(GL,3);
GM2:=EMA(GL,10);
A1:=EMA(CC,7)-EMA(CC,21);
B1:=EMA((0.618*REF(A1,1)+0.382*A1),1);
STICKLINE(A1>B1,M2,M3,0.3,0.1),COLORRED;
STICKLINE(A1<B1,M2,M3,0.3,0.1),COLORCYAN;{乖离}
BOLL:MA(CC,N),DOTLINE,COLORWHITE;
UB:BOLL+2*STD(CC,N),DOTLINE,COLORLIRED;
LB:BOLL-2*STD(CC,N),DOTLINE,COLORLIBLUE;{BOLL用于区分顶底};
{买点}{牛牛指标网提供 www.tdx001.com}
A9:=EMA(C,2)-EMA(C,55);
A10:=EMA(A9,13);
A11:=2*(A9-A10);
ZL:=100*POW(A11,3)*0.1+100*POW(A11,1);
DRAWICON(CROSS(ZL,0),COL,31);

034377266.jpg

034377266.jpg

034500672.jpg

034500672.jpg

03511297.jpg

03511297.jpg

035122704.jpg

035122704.jpg

 

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则