通达信公式11压力支撑.A股现货应该T+0.股指期货应该T+5指标

[复制链接]
查看2010 | 回复0 | 2022-7-24 08:15:58 | 显示全部楼层 |阅读模式

通达信公式11压力支撑.A股现货应该T+0.股指期货应该T+5指标

A股是小菜。股指期货才是大餐。5日A股成交854亿1212股指8149亿。6日A股成交584亿1212股指5362亿。7日A股成交821亿1212股指7637亿。
 公式11压力支撑.A股现货应该T+0.股指期货应该T+5。
 
{113压力支撑}
 HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
 AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
 QY:=BACKSET(AA,HIGHN+1);
 CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
 DRAWICON(CC,H*1.02,2);
 DDD:=BARSLAST(CC);
 GDTS:=IF(CC,CURRBARSCOUNT,0);
 DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
 DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
 DINGBU1:=REF(DINGBU,DDD+1);
 GDCS1:=CONST(DINGBUTS);
 DINGBUTS1:=REF(DINGBUTS,DDD+1);
 GDCS2:=CONST(DINGBUTS1);
 DINGBU2:=REF(DINGBU1,DDD+1);
 MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
 高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;
 DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
 DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
 AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
 QY1:=BACKSET(AA1,LOWN+1);
 CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
 DRAWICON(CC1,L*0.98,1);
 DD1:=BARSLAST(CC1);
 DDTS:=IF(CC1,CURRBARSCOUNT,0);
 YDB:=IF(DD1,REF(L,DD1),L);
 DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
 DDCS1:=CONST(DDTS1);
 ZDB:=REF(YDB,DD1+1);
 DDTS2:=REF(DDTS1,DD1+1);
 DDCS2:=CONST(DDTS2);
 低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK2;
 ZGSTAR:=(高点压力+低点支撑)/2;
 ZGEND:=CONST((高点压力+低点支撑)/2);
 STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
 中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK2;
 DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT,;
 DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;
 EMA13:=EMA(C,13),COLORWHITE;
EMA21:=EMA(C,21),COLORYELLOW;
EMA34:=EMA(C,34),COLORFF00FF;
EMA60:=MA(C,60),COLORFFCC66;
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN;
DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
 S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;{牛牛指标网提供 www.tdx001.com}
 A1:EMA(A0,14)COLORBLUE,LINETHICK2;
 A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;
 A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
 A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
 看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};
 逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};
 买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK3;
 卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK3;
 STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
 STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;
 

954311585.png

954311585.png

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则