通达信没有未来函数的超级好用指标—红买绿卖副图公式

[复制链接]
查看1519 | 回复0 | 2022-7-24 08:07:07 | 显示全部楼层 |阅读模式

通达信没有未来函数的超级好用指标—红买绿卖副图公式

AAA:=EMA(CLOSE,1);
 庄影难逃:=EMA((AAA-REF(AAA,1))/REF(AAA,1),1)*100;
 BBB:=EMA(庄影难逃,5);
 CCC:=EMA(BBB,11);
 主力动向:=(EMA(BBB+CCC,1)-EMA(BBB-CCC,1))*50,COLORFF00FF,NODRAW;
 DDD:EMA(主力动向,11)*10,COLORFF00FF,NODRAW;
 主力:=DDD;
 AA:0;
 STICKLINE(主力<0,主力,0,4,0),COLOR009900;
 STICKLINE(主力<0,主力,0,3,0),COLOR00BB00;
 STICKLINE(主力<0,主力,0,2,0),COLOR00DD00;
 STICKLINE(主力<0,主力,0,1,0),COLOR00FF00;
 STICKLINE(主力>REF(主力,1) AND 主力<0,主力,0,4,0),COLORFF6600;
 STICKLINE(主力>REF(主力,1) AND 主力<0,主力,0,3,0),COLORFF9900;
 STICKLINE(主力>REF(主力,1) AND 主力<0,主力,0,2,0),COLORFFCC00;
 STICKLINE(主力>REF(主力,1) AND 主力<0,主力,0,1,0),COLORCYAN;
 STICKLINE(主力>REF(主力,1) AND 主力>0,主力,0,4,0),COLOR000099;
 STICKLINE(主力>REF(主力,1) AND 主力>0,主力,0,3,0),COLOR0000BB;
 STICKLINE(主力>REF(主力,1) AND 主力>0,主力,0,1.5,0),COLOR0000DD;
 STICKLINE(主力>REF(主力,1) AND 主力>0,主力,0,0.5,0),COLOR0000FF;
 VAR2:=EXPMEMA(EMA(WINNER(C)*100,2),1);
 STICKLINE(VAR2>50 AND COST(60)<C AND 主力>0,主力,0,4,0),COLOR000099;
 STICKLINE(VAR2>50 AND COST(60)<C AND 主力>0,主力,0,3,0),COLOR0000BB;
 STICKLINE(VAR2>50 AND COST(60)<C AND 主力>0,主力,0,2,0),COLOR0000DD;
 STICKLINE(VAR2>50 AND COST(60)<C AND 主力>0,主力,0,1,0),COLOR0000FF;
 STICKLINE(主力<REF(主力,1) AND 主力>0,主力,0,4,0),COLOR000099;
 STICKLINE(主力<REF(主力,1) AND 主力>0,主力,0,3,0),COLOR0000CC;
 STICKLINE(主力<REF(主力,1) AND 主力>0,主力,0,2,0),COLOR0000FF;
 STICKLINE(主力<REF(主力,1) AND 主力>0,主力,0,1,0),COLORCC99FF;
 
 

1318577637.jpg

1318577637.jpg

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则