通达信竞价抓牛股源码

[复制链接]
查看1727 | 回复0 | 2022-7-24 04:25:01 | 显示全部楼层 |阅读模式

竞价抓牛股源码

X_1:=REF(HIGH,1)=HHV(HIGH,2*1+1);
 X_2:=FILTER(X_1,1);
 X_3:=BACKSET(X_2,1+1);
 X_4:=FILTER(X_3,1);
 X_5:=REF(LOW,1)=LLV(LOW,2*1+1);
 X_6:=FILTER(X_5,1);
 X_7:=BACKSET(X_6,1+1);
 X_8:=FILTER(X_7,1);
 X_9:=(REF(LLV(LOW,2*1),1)+REF(HHV(HIGH,2*1),1))/2;
 X_10:=(HIGH+LOW)/2;
 X_11:=X_4 AND NOT(X_8 AND X_9>=X_10) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
 X_12:=X_8 AND NOT(X_4 AND X_9<X_10);
 X_13:=X_4 AND NOT(X_8 AND X_9>=X_10);
 X_14:=REF(BARSLAST(X_11),1)+1;
 X_15:=BACKSET(X_11 AND COUNT(X_12,X_14)>0,LLVBARS(IF(X_12,LOW,10000),X_14));
 X_16:=X_15>REF(X_15,1);
 X_17:=BACKSET(X_16,2);
 X_18:=X_17>REF(X_17,1);
 X_19:=X_18 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
 X_20:=REF(BARSLAST(X_19),1)+1;
 X_21:=BACKSET(X_19 AND COUNT(X_13,X_20)>0,HHVBARS(IF(X_13,HIGH,0),X_20));
 X_22:=X_21>REF(X_21,1);
 X_23:=BACKSET(X_22,2);
 X_24:=X_23>REF(X_23,1);
 X_25:=BACKSET(ISLASTBAR,BARSLAST(X_24)+1);
 X_26:=X_25>REF(X_25,1);
 X_27:=BACKSET(ISLASTBAR,BARSLAST(X_18)+1);
 X_28:=X_27>REF(X_27,1);
 X_29:=BACKSET(X_26,REF(BARSLAST(X_24),1)+2);
 X_30:=X_29>REF(X_29,1);
 X_31:=BACKSET(X_28,REF(BARSLAST(X_18),1)+2);
 X_32:=X_31>REF(X_31,1);
 X_33:=DRAWLINE(X_30,HIGH,X_26,HIGH,1);
 X_34:=DRAWLINE(X_32,LOW,X_28,LOW,1);
跳空突破:OPEN>X_33 AND REF(CLOSE,1)<X_33 AND OPEN>REF(CLOSE,1),COLORRED,LINETHICK3;
 

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则