通达信分时九转思路解析已完美实现

[复制链接]
查看153 | 回复0 | 2022-7-8 10:47:36 | 显示全部楼层 |阅读模式

钻研指标技术5年多,只要不牵扯到程序化交易,基本都可以编写(因为通达信、大智慧函数库的无法实现程序化交易),自我介绍完毕

开始正题,前阵子徐小明老师(我很崇拜)整了一个分时九转,搞火了飞狐,突然来了兴趣,就想在通达信上看看能不能实现,倒腾了几天,果真实现了,不多说,规矩我懂,上图。
 

原理解析:借用了迪马克TD序列的思想,行家都懂,飞狐应该是调用了软件本身的DLL,所以实现起来很简单,苦于通达信函数库限制,我用了很多IF判断,最终还是完美实现了

买入起点:REF(CLOSE,1)>REF(CLOSE,5) AND CLOSE<REF(CLOSE,4) NODRAW;
 {DRAWTEXT(买入起点,LOW*0.996,'1') COLORYELLOW;}
买起至今:BARSLAST(买入起点) NODRAW;
卖出起点:REF(CLOSE,1)<REF(CLOSE,5) AND CLOSE>REF(CLOSE,4) NODRAW;
 {DRAWTEXT(卖出起点,HIGH*1,'1') COLORBLUE;}
卖起至今:BARSLAST(卖出起点) NODRAW;
买入低四:CLOSE<REF(CLOSE,4) NODRAW;
买低计数:BARSLASTCOUNT(买入低四) NODRAW;
买中断今:BARSLAST(买低计数>0 AND REFX(买低计数,1)=0) NODRAW;
后点买今:REF(买低计数,买中断今)+1 NODRAW;

654233101.jpg

654233101.jpg

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则