通达信牛熊操盘 BS分时主图主力动向公式组

[复制链接]
查看102 | 回复0 | 2022-7-8 09:21:23 | 显示全部楼层 |阅读模式

牛熊操盘 BS分时主图 主力动向 公式组

{公式名称: 主力动向}

 

VAR1:=CAPITAL*100/100000000;

VAR2:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),FROMOPEN);

VAR3:=-SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),FROMOPEN);

VAR4:=VAR2+VAR3;

VAR5:=2400;

VAR6:=HHV(VAR4,VAR5);

VAR7:=LLV(VAR4,VAR5);

VAR8:=CONST(VAR6);

VAR9:=CONST(VAR7);

VAR10:=VAR8;

VAR11:=VAR9;

VAR12:=(VAR10+VAR11)/2;

VAR13:=VAR10-VAR11;

VAR14:=(100-0)/2*1.3;

VAR15:=(100-0)/1*1.3;

VAR16:=(50-VAR14)*VAR13/VAR15+VAR12;

VAR17:=VAR8-VAR9;

DRAWBAND(VAR4,RGB(150,0,150),0,RGB(0,100,0));

资金流量:VAR4,COLORWHITE;

资金比:VAR4/SUM(VOL,FROMOPEN)*100,COLORYELLOW;

VAR18:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2));

 


{BS分时主图}

{主图叠加}

 

均价:SUM(CLOSE*VOL,0)/SUM(VOL,0),COLORYELLOW;

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE/均价>1+0.015;

VAR2:=CLOSE<REF(CLOSE,1) AND CLOSE/均价<1-0.015;

VAR3:=CROSS(SUM(VAR1,0),0.5);

VAR4:=CROSS(SUM(VAR2,0),0.5);

VAR5:=SUM(VAR3,0)*CROSS(COUNT(CLOSE<REF(CLOSE,1),BARSLAST(VAR3)),0.5);

VAR6:=SUM(VAR4,0)*CROSS(COUNT(CLOSE>REF(CLOSE,1),BARSLAST(VAR4)),0.5);

VAR7:=CONST(SUM(IF(VAR5,REF(CLOSE,1),DRAWNULL),0));

VAR8:=CONST(SUM(IF(VAR6,REF(CLOSE,1),DRAWNULL),0));

VAR9:=CROSS(SUM(VAR1 AND CLOSE>VAR7*(1+0.015),0),0.5);

VAR10:=CROSS(SUM(VAR2 AND CLOSE<VAR8*(1-0.015),0),0.5);

VAR11:=CROSS(SUM(VAR9,0),0.5);
 

VAR12:=CROSS(SUM(VAR10,0),0.5);

VAR13:=SUM(VAR11,0)*CROSS(COUNT(CLOSE<REF(CLOSE,1),BARSLAST(VAR11)),0.5);

VAR14:=SUM(VAR12,0)*CROSS(COUNT(CLOSE>REF(CLOSE,1),BARSLAST(VAR12)),0.5);

VAR15:=CONST(SUM(IF(VAR13,REF(CLOSE,1),DRAWNULL),0));

VAR16:=CONST(SUM(IF(VAR14,REF(CLOSE,1),DRAWNULL),0));

VAR17:=CROSS(SUM(VAR1 AND CLOSE>VAR15*(1+0.03),0),0.5);

VAR18:=CROSS(SUM(VAR2 AND CLOSE<VAR16*(1+0.03),0),0.5);

VAR19:=SUM(VAR17,0)*CROSS(COUNT(CLOSE<REF(CLOSE,1),BARSLAST(VAR17)),0.5);

VAR20:=SUM(VAR18,0)*CROSS(COUNT(CLOSE>REF(CLOSE,1),BARSLAST(VAR18)),0.5);

VAR21:=CONST(SUM(IF(VAR19,REF(CLOSE,1),DRAWNULL),0));

VAR22:=CONST(SUM(IF(VAR20,REF(CLOSE,1),DRAWNULL),0));

DRAWICON(VAR3 OR VAR11 OR VAR17,CLOSE*1.01,16);

DRAWICON(VAR4 OR VAR12 OR VAR18,CLOSE*0.99,18);

DRAWICON(VAR6 OR VAR14 OR VAR20,REF(CLOSE,1)*0.99,22);

DRAWICON(VAR5 OR VAR13 OR VAR19,REF(CLOSE,1)*1.01,21);

DRAWNUMBER(VAR5 OR VAR13 OR VAR19,CLOSE*1.03,CLOSE),COLORGREEN;

DRAWNUMBER(VAR6 OR VAR14 OR VAR20,CLOSE*0.97,CLOSE),COLORRED;

VAR23:=BARSLAST(TIME=93100);

VAR24:=HHV(HIGH,VAR23+1);

VAR25:=LLV(LOW,VAR23+1);

VAR26:=BETWEEN(TIME2,93100,100000);

VAR27:=IF(VAR26,VAR24,DRAWNULL)=CLOSE;

VAR28:=IF(VAR26,VAR25,DRAWNULL)=CLOSE;

VAR29:=BARSLAST(IF(FILTERX(VAR27,VAR23),1,0));

VAR30:=BARSLAST(IF(FILTERX(VAR28,VAR23),1,0));

T6E:CONST(REF(CLOSE,VAR29)),DOTLINE,COLORMAGENTA;

T6F:CONST(REF(CLOSE,VAR30)),DOTLINE,COLORGREEN;

{公式名称: 牛熊操盘}

{主图叠加}

VAR1:=MA(CLOSE,18);

VAR2:=MA(CLOSE,72);

STICKLINE(CLOSE>=0,HIGH,LOW,0,0),COLORLIMAGENTA;

STICKLINE(CLOSE>=0 AND CLOSE>=OPEN,OPEN,CLOSE,(-1),1),COLORLIMAGENTA;

STICKLINE(CLOSE>=0 AND CLOSE<=OPEN,OPEN,CLOSE,(-1),0),COLORLIMAGENTA;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1),HIGH,LOW,0,0),COLOR0000A8;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE>=OPEN,OPEN,CLOSE,(-1),1),COLOR0000A8;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE<=OPEN,OPEN,CLOSE,(-1),0),COLOR0000A8;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2,HIGH,LOW,0,0),COLORFFFF80;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE>=OPEN,OPEN,CLOSE,(-1),1),COLORFFFF80;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE<=OPEN,OPEN,CLOSE,(-1),0),COLORFFFF80;

STICKLINE(CLOSE<VAR2,HIGH,LOW,0,0),COLOR804000;

STICKLINE(CLOSE<VAR2 AND CLOSE>=OPEN,OPEN,CLOSE,(-1),1),COLOR804000;

STICKLINE(CLOSE<VAR2 AND CLOSE<=OPEN,OPEN,CLOSE,(-1),0),COLOR804000;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2,HIGH,LOW,0,0),COLORGRAY;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE>=OPEN,OPEN,CLOSE,(-1),1),COLORGRAY;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE<=OPEN,OPEN,CLOSE,(-1),0),COLORGRAY;

VAR3:=NAMELIKE(8) OR NAMELIKE(9) OR NAMELIKE(10);

VAR4:=REF(CLOSE,1);

VAR5:=IF(1.05*VAR4-CLOSE<0.005,1,0) AND VAR3;

VAR6:=IF(1.1*VAR4-CLOSE<0.005,1,0);

VAR7:=VAR5 OR VAR6;

STICKLINE(VAR7,OPEN,CLOSE,(-1),0),COLORYELLOW;

STICKLINE(VAR7,HIGH,LOW,0,0),COLORYELLOW;

STICKLINE(VAR7,OPEN*1.005,CLOSE*0.995,1,(-1)),COLORYELLOW;

STICKLINE(CLOSE>=0 AND CLOSE>=OPEN AND VAR7,OPEN*1.006,CLOSE*0.994,0.8,0),COLORLIMAGENTA;

STICKLINE(CLOSE>=0 AND CLOSE<=OPEN AND VAR7,OPEN*0.994,CLOSE*1.006,0.8,0),COLORLIMAGENTA;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE>=OPEN AND VAR7,OPEN*1.006,CLOSE*0.994,0.8,0),COLOR0000A8;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE<=OPEN AND VAR7,OPEN*0.994,CLOSE*1.006,0.8,0),COLOR0000A8;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE>=OPEN AND VAR7,OPEN*1.006,CLOSE*0.994,0.8,0),COLORFFFF80;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE<=OPEN AND VAR7,OPEN*0.994,CLOSE*1.006,0.8,0),COLORFFFF80;

STICKLINE(CLOSE<VAR2 AND CLOSE>=OPEN AND VAR7,OPEN*1.006,CLOSE*0.994,0.8,0),COLOR804000;

STICKLINE(CLOSE<VAR2 AND CLOSE<=OPEN AND VAR7,OPEN*0.994,CLOSE*1.006,0.8,0),COLOR804000;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE>=OPEN AND VAR7,OPEN*1.006,CLOSE*0.994,0.8,0),COLORGRAY;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE<=OPEN AND VAR7,OPEN*0.994,CLOSE*1.006,0.8,0),COLORGRAY;

VAR8:=IF(CLOSE-0.95*VAR4<0.005,1,0) AND VAR3;

VAR9:=IF(CLOSE-0.9*VAR4<0.005,1,0);

VAR10:=VAR8 OR VAR9;

STICKLINE(VAR10,OPEN,CLOSE,(-1),0),COLORGREEN;

STICKLINE(VAR10,HIGH,LOW,0,1),COLORGREEN;

STICKLINE(VAR10,OPEN*0.995,CLOSE*1.005,1,(-1)),COLORGREEN;

STICKLINE(CLOSE>=0 AND CLOSE>=OPEN AND VAR10,OPEN*1.006,CLOSE*0.994,0.8,0),COLORLIMAGENTA;

STICKLINE(CLOSE>=0 AND CLOSE<=OPEN AND VAR10,OPEN*0.994,CLOSE*1.006,0.8,0),COLORLIMAGENTA;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE>=OPEN AND VAR10,OPEN*1.006,CLOSE*0.994,0.8,0),COLOR0000A8;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE<=OPEN AND VAR10,OPEN*0.994,CLOSE*1.006,0.8,0),COLOR0000A8;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE>=OPEN AND VAR10,OPEN*1.006,CLOSE*0.994,0.8,0),COLORFFFF80;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE<=OPEN AND VAR10,OPEN*0.994,CLOSE*1.006,0.8,0),COLORFFFF80;

STICKLINE(CLOSE<VAR2 AND CLOSE>=OPEN AND VAR10,OPEN*1.006,CLOSE*0.994,0.8,0),COLOR804000;

STICKLINE(CLOSE<VAR2 AND CLOSE<=OPEN AND VAR10,OPEN*0.994,CLOSE*1.006,0.8,0),COLOR804000;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE>=OPEN AND VAR10,OPEN*1.006,CLOSE*0.994,0.8,0),COLORGRAY;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE<=OPEN AND VAR10,OPEN*0.994,CLOSE*1.006,0.8,0),COLORGRAY;

VAR11:=IF((CLOSE-VAR4)*100/VAR4>=5-0.01*100/VAR4,1,0);

VAR12:=IF((CLOSE-VAR4)*100/VAR4<10-0.01*100/VAR4,1,0);

VAR13:=VAR11 AND VAR12 AND NOT(VAR3);

STICKLINE(VAR13,OPEN,CLOSE,(-1),0),COLOR006AD5;

STICKLINE(VAR13,HIGH,LOW,0,0),COLOR006AD5;

STICKLINE(VAR13 AND CLOSE>OPEN,OPEN*1.005,CLOSE*0.995,1,(-1)),COLOR006AD5;

STICKLINE(VAR13 AND CLOSE<OPEN,OPEN*0.995,CLOSE*1.005,1,(-1)),COLOR006AD5;

STICKLINE(CLOSE>=0 AND CLOSE>=OPEN AND VAR13,OPEN*1.006,CLOSE*0.994,0.8,0),COLORLIMAGENTA;

STICKLINE(CLOSE>=0 AND CLOSE<=OPEN AND VAR13,OPEN*0.994,CLOSE*1.006,0.8,0),COLORLIMAGENTA;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE>=OPEN AND VAR13,OPEN*1.006,CLOSE*0.994,0.8,0),COLOR0000A8;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE<=OPEN AND VAR13,OPEN*0.994,CLOSE*1.006,0.8,0),COLOR0000A8;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE>=OPEN AND VAR13,OPEN*1.006,CLOSE*0.994,0.8,0),COLORFFFF80;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE<=OPEN AND VAR13,OPEN*0.994,CLOSE*1.006,0.8,0),COLORFFFF80;

STICKLINE(CLOSE<VAR2 AND CLOSE>=OPEN AND VAR13,OPEN*1.006,CLOSE*0.994,0.8,0),COLOR804000;

STICKLINE(CLOSE<VAR2 AND CLOSE<=OPEN AND VAR13,OPEN*0.994,CLOSE*1.006,0.8,0),COLOR804000;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE>=OPEN AND VAR13,OPEN*1.006,CLOSE*0.994,0.8,0),COLORGRAY;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE<=OPEN AND VAR13,OPEN*0.994,CLOSE*1.006,0.8,0),COLORGRAY;

VAR14:=IF((VAR4-CLOSE)*100/VAR4>=5-0.01*100/CLOSE,1,0);

VAR15:=IF((VAR4-CLOSE)*100/VAR4<=10-0.01*100/CLOSE,1,0);

VAR16:=VAR14 AND VAR15 AND NOT(VAR3);

STICKLINE(VAR16,OPEN,CLOSE,(-1),0),COLOR008000;

STICKLINE(VAR16,HIGH,LOW,0,0),COLOR008000;

STICKLINE(VAR16 AND CLOSE<OPEN,OPEN*0.995,CLOSE*1.005,1,(-1)),COLOR008000;

STICKLINE(VAR16 AND CLOSE>OPEN,OPEN*1.005,CLOSE*0.995,1,(-1)),COLOR008000;

STICKLINE(CLOSE>=0 AND CLOSE>=OPEN AND VAR16,OPEN*1.006,CLOSE*0.994,0.8,0),COLORLIMAGENTA;

STICKLINE(CLOSE>=0 AND CLOSE<=OPEN AND VAR16,OPEN*0.994,CLOSE*1.006,0.8,0),COLORLIMAGENTA;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE>=OPEN AND VAR16,OPEN*1.006,CLOSE*0.994,0.8,0),COLOR0000A8;

STICKLINE(CLOSE>VAR1 AND VAR1>REF(VAR1,1) AND CLOSE<=OPEN AND VAR16,OPEN*0.994,CLOSE*1.006,0.8,0),COLOR0000A8;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE>=OPEN AND VAR16,OPEN*1.006,CLOSE*0.994,0.8,0),COLORFFFF80;

STICKLINE(CLOSE<VAR1 AND CLOSE>VAR2 AND CLOSE<=OPEN AND VAR16,OPEN*0.994,CLOSE*1.006,0.8,0),COLORFFFF80;

STICKLINE(CLOSE<VAR2 AND CLOSE>=OPEN AND VAR16,OPEN*1.006,CLOSE*0.994,0.8,0),COLOR804000;

STICKLINE(CLOSE<VAR2 AND CLOSE<=OPEN AND VAR16,OPEN*0.994,CLOSE*1.006,0.8,0),COLOR804000;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE>=OPEN AND VAR16,OPEN*1.006,CLOSE*0.994,0.8,0),COLORGRAY;

STICKLINE(CLOSE>VAR1 AND VAR1<VAR2 AND CLOSE<=OPEN AND VAR16,OPEN*0.994,CLOSE*1.006,0.8,0),COLORGRAY;

DRAWNUMBER(VAR13,HIGH*1.03,(CLOSE-VAR4)*100/VAR4)+11,COLORRED;

DRAWNUMBER(VAR16,LOW*0.97,(-(VAR4-CLOSE))*100/VAR4),COLORGREEN;
 

62311343.png

62311343.png

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则