通达信经过加工的分时资金源码副图

[复制链接]
查看85 | 回复0 | 2022-7-8 08:39:44 | 显示全部楼层 |阅读模式

{此为通达信分时副图}

成交额:=V*C/100,NODRAW;{万元}

A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);

A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);

A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);

A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);

A6:=((A2+A3)+A4)+A5;

A7:=IF((ISLASTBAR),((100*A2)/A6),0);

A8:=IF((ISLASTBAR),((100*A3)/A6),0);

A9:=IF((ISLASTBAR),((100*A4)/A6),0);

A10:=IF((ISLASTBAR),((100*A5)/A6),0);

机构买:(A2),LINETHICK6,COLORRED;

机构卖:(A3),LINETHICK6,COLORFFFF55;

机构净:机构买-机构卖,COLORYELLOW,NODRAW;

散户买:(A4),COLOR5555FF;{细红线}

散户卖:(A5),COLOR55FF55;{细绿线}

散户净:散户买-散户卖,COLORBLUE;

总净:机构净+散户净,COLORMAGENTA{,NODRAW};

强势:((100*A2)/A6>50),COLORYELLOW,NODRAW;

STICKLINE(强势,机构买*1.02,机构买*1.1,1,0),COLORYELLOW;

拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18,COLORFF00FF,NODRAW;

STICKLINE(拉升,机构买*1.1,机构买*1.2,1,0),COLORFF00FF;

DRAWTEXT(ISLASTBAR=1,机构买*0.95,'●机构买'),LINETHICK2,COLORRED;

DRAWTEXT(ISLASTBAR=1,机构卖*0.95,'○机构卖'),LINETHICK2,COLORFFFF55;

DRAWTEXT(机构净>0 AND REF(机构净,1)<=0,机构买*1.02,'●机买'),COLORRED;

DRAWTEXT(机构净<0 AND REF(机构净,1)>=0,机构买*0.98,'○机卖'),COLORFFFF55;

DD1:=1;

AAA1:=STRCAT(STRCAT('机构买',CON2STR((100*A2)/A6,0)),'%%');

AAA2:=STRCAT(STRCAT('机构卖',CON2STR((100*A3)/A6,0)),'%%');

AAA3:=STRCAT(STRCAT('散户买',CON2STR((100*A4)/A6,0)),'%%');

AAA4:=STRCAT(STRCAT('散户卖',CON2STR((100*A5)/A6,0)),'%%');

DRAWTEXT_FIX(DD1=1,0,0.02,0,AAA1),COLORRED;

DRAWTEXT_FIX(DD1=1,0,0.13,0,AAA2),COLORFFFF55;

DRAWTEXT_FIX(DD1=1,0,0.24,0,AAA3),COLOR5555FF;

DRAWTEXT_FIX(DD1=1,0,0.35,0,AAA4),COLOR55FF55;

DRAWNUMBER(ISLASTBAR  ,总净,总净),COLORMAGENTA;

DRAWTEXT(ISLASTBAR=1,总净,'                     (↖总净_万元)'),COLORMAGENTA;

78422627.png

78422627.png

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则